// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)0?(?P<month>10|11|12|1|2|3|4|5|6|7|8|9)[—](?P<day>[1-2][0-9]|3[0-1]|[0]?[1-9])[—](?P<year>(19|20)\d{2})[ ](?P<desc>.*?)[ ](?P<amount>[-]?[S]?\d*\.\d+)").unwrap();
let string = "11—04—2022 ACH Deposit Square Inc 221104P2 126.42
11—07—2022 ACH Deposit Square Inc 221107P2 184.86
11—07—2022 ACH Deposit Square Inc 221107P2 225.67
11—09—2022 ACH Deposit Square Inc 221109P2 277.19
11—10—2022 ACH Deposit Square Inc 221110P2 306.31
11—14—2022 ACH Deposit Square Inc 221114P2 19.38
11—14—2022 ACH Deposit Square Inc 221111P2 126.42
11—14—2022 ACH Deposit Square Inc 221114P2 213.98
11—16—2022 ACH Deposit Square Inc 221116P2 175.02
11—17—2022 ACH Deposit Square Inc 221117P2 157.49
11—18—2022 ACH Deposit Square Inc 221118P2 308.4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}