package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:\w+ DT )?(?:\w+ JJ )*)?\w+ (?:N[NP]|PRN)`)
var str = `he PRN and CC bill NP could MOD hear VB them PRN on IN the DT large JJ balcony NN near IN the DT house NN
the DT big JJ store NN he PRN bought VBD ripe JJ bananas NN.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}