const regex = /(?:(?:\w+ DT )?(?:\w+ JJ )*)?\w+ (?:N[NP]|PRN)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\w+ DT )?(?:\\w+ JJ )*)?\\w+ (?:N[NP]|PRN)', 'gm')
const str = `he PRN and CC bill NP could MOD hear VB them PRN on IN the DT large JJ balcony NN near IN the DT house NN
the DT big JJ store NN he PRN bought VBD ripe JJ bananas NN.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);