import re
regex = re.compile(r"(?:(?:\w+ DT )?(?:\w+ JJ )*)?\w+ (?:N[NP]|PRN)", flags=re.MULTILINE)
test_str = ("he PRN and CC bill NP could MOD hear VB them PRN on IN the DT large JJ balcony NN near IN the DT house NN\n"
" the DT big JJ store NN he PRN bought VBD ripe JJ bananas NN.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)