re = /(?:(?:\w+ DT )?(?:\w+ JJ )*)?\w+ (?:N[NP]|PRN)/m
str = 'he PRN and CC bill NP could MOD hear VB them PRN on IN the DT large JJ balcony NN near IN the DT house NN
the DT big JJ store NN he PRN bought VBD ripe JJ bananas NN.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result