const regex = /test_function\((?!\w+\('[^'\\]*(?:\\.[^'\\]*)*'(?:,(?:true|false))*\)\)|'[^'\\]*(?:\\.[^'\\]*)*'\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('test_function\\((?!\\w+\\(\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'(?:,(?:true|false))*\\)\\)|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'\\))', 'g')
const str = `test_function('something',true);
test_function('something',false);
test_function('something',true,true);
test_function(another_function('anotherthing',true),true);
don't want to find this:
test_function('something');
test_function('something').another_function(something,true);
test_function(another_function('anotherthing',true));`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}