$re = '/test_function\((?!\w+\(\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'(?:,(?:true|false))*\)\)|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'\))/';
$str = 'test_function(\'something\',true);
test_function(\'something\',false);
test_function(\'something\',true,true);
test_function(another_function(\'anotherthing\',true),true);
don\'t want to find this:
test_function(\'something\');
test_function(\'something\').another_function(something,true);
test_function(another_function(\'anotherthing\',true));';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);