re = /test_function\((?!\w+\('[^'\\]*(?:\\.[^'\\]*)*'(?:,(?:true|false))*\)\)|'[^'\\]*(?:\\.[^'\\]*)*'\))/
str = 'test_function(\'something\',true);
test_function(\'something\',false);
test_function(\'something\',true,true);
test_function(another_function(\'anotherthing\',true),true);
don\'t want to find this:
test_function(\'something\');
test_function(\'something\').another_function(something,true);
test_function(another_function(\'anotherthing\',true));'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end