$re = '/Ваш заказ доступен по адресу:(?:\s++(?:[а-яА-Я\w\d,!]++|\.)*?){1,3}\s*+\.\sЗабирайте скорее!$/';
$str = 'Ваш заказ доступен по адресу: dfdfdf dfdfdfdfdfdfdfdfdfdfd sfdnjв. Забирайте скорее!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);