// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Ваш заказ доступен по адресу:(?:\s++(?:[а-яА-Я\w\d,!]++|\.)*?){1,3}\s*+\.\sЗабирайте скорее!$").unwrap();
let string = "Ваш заказ доступен по адресу: dfdfdf dfdfdfdfdfdfdfdfdfdfd sfdnjв. Забирайте скорее!";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}