import Foundation
let pattern = #"Ваш заказ доступен по адресу:(?:\s++(?:[а-яА-Я\w\d,!]++|\.)*?){1,3}\s*+\.\sЗабирайте скорее!$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Ваш заказ доступен по адресу: dfdfdf dfdfdfdfdfdfdfdfdfdfd sfdnjв. Забирайте скорее!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}