import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\w{0,2}\\b(?:'\\w)?|\\b\\w{3}(?!')\\b|\\b\\w{5,}\\b|('?\\b\\w+\\b'?\\w?)";
final String string = "This Jon's dogs' 'bout there in word re'y.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}