re = /\b\w{0,2}\b(?:'\w)?|\b\w{3}(?!')\b|\b\w{5,}\b|('?\b\w+\b'?\w?)/
str = 'This Jon\'s dogs\' \'bout there in word re\'y.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end