const regex = /\b\w{0,2}\b(?:'\w)?|\b\w{3}(?!')\b|\b\w{5,}\b|('?\b\w+\b'?\w?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\w{0,2}\\b(?:\'\\w)?|\\b\\w{3}(?!\')\\b|\\b\\w{5,}\\b|(\'?\\b\\w+\\b\'?\\w?)', 'g')
const str = `This Jon's dogs' 'bout there in word re'y.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}