$re = '/\b\w{0,2}\b(?:\'\w)?|\b\w{3}(?!\')\b|\b\w{5,}\b|(\'?\b\w+\b\'?\w?)/';
$str = 'This Jon\'s dogs\' \'bout there in word re\'y.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);