using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.)(?=[\s\S]*\n[^\n]*\1(.)(?:[^\n]{2})*\n?(?![\s\S]))";
string input = @"dfgnsaAаАsоdbf;ihgо
ds
fgdsfhg
AАBВEЕKКMМHНOОPРCСTТXХaаeеoоpрcсyуxх";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}