re = /(.)(?=[\s\S]*\n[^\n]*\1(.)(?:[^\n]{2})*\n?(?![\s\S]))/
str = 'dfgnsaAаАsоdbf;ihgо
ds
fgdsfhg
AАBВEЕKКMМHНOОPРCСTТXХaаeеoоpрcсyуxх'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end