$re = '/(.)(?=[\s\S]*\n[^\n]*\1(.)(?:[^\n]{2})*\n?(?![\s\S]))/';
$str = 'dfgnsaAаАsоdbf;ihgо
ds
fgdsfhg
AАBВEЕKКMМHНOОPРCСTТXХaаeеoоpрcсyуxх';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);