import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.)(?=[\\s\\S]*\\n[^\\n]*\\1(.)(?:[^\\n]{2})*\\n?(?![\\s\\S]))";
final String string = "dfgnsaAаАsоdbf;ihgо\n"
+ "ds\n"
+ "fgdsfhg\n"
+ "AАBВEЕKКMМHНOОPРCСTТXХaаeеoоpрcсyуxх";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}