import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{photo::start\\}\\}(\\X+)\\{\\{photo::stop\\}\\}";
final String string = " \n"
+ " </div>\n"
+ " \n"
+ " \n"
+ " <!-- Gallery -->\n"
+ " \n"
+ " <div id=\"ap-product-gallery\" class=\"ap-cf\">\n"
+ " {{photo::start}}\n"
+ " <div class=\"ap-pg-photo-wrapper\">\n"
+ " <img src=\" class=\"a\" width=\"586\" />\n"
+ " </div>{{photo::stop}}\n"
+ " \n"
+ " <div class=\"ap-pg-photo-wrapper\">\n"
+ " <img src=\"link.jpg\" class=\"ap-pg-photo\" width=\"586\" />\n"
+ " </div>\n"
+ " \n"
+ " <div class=\"ap-pg-photo-wrapper\">\n"
+ " <img src=\"link.jpg\" class=\"ap-pg-photo\" width=\"586\" />\n"
+ " </div>\n"
+ " \n"
+ " <div class=\"ap-pg-photo-wrapper\">\n"
+ " <img src=\"link.jpg\" class=\"ap-pg-photo\" width=\"586\" />\n"
+ " </div>\n"
+ " \n"
+ " </div>\n"
+ " \n"
+ " \n"
+ " <!-- Banner -->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}