use strict;
my $str = '
</div>
<!-- Gallery -->
<div id="ap-product-gallery" class="ap-cf">
{{photo::start}}
<div class="ap-pg-photo-wrapper">
<img src=" class="a" width="586" />
</div>{{photo::stop}}
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
</div>
<!-- Banner -->';
my $regex = qr/{{photo::start}}(\X+){{photo::stop}}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}