import Foundation
let pattern = #"{{photo::start}}(\X+){{photo::stop}}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
</div>
<!-- Gallery -->
<div id="ap-product-gallery" class="ap-cf">
{{photo::start}}
<div class="ap-pg-photo-wrapper">
<img src=" class="a" width="586" />
</div>{{photo::stop}}
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
</div>
<!-- Banner -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)