$re = '/{{photo::start}}(\X+){{photo::stop}}/';
$str = '
</div>
<!-- Gallery -->
<div id="ap-product-gallery" class="ap-cf">
{{photo::start}}
<div class="ap-pg-photo-wrapper">
<img src=" class="a" width="586" />
</div>{{photo::stop}}
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
<div class="ap-pg-photo-wrapper">
<img src="link.jpg" class="ap-pg-photo" width="586" />
</div>
</div>
<!-- Banner -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);