import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\{2}sin|cos|tan|sec|log)([^^]*)(\\^\\{[^\\}]*\\})";
final String string = "\\\\sin\\\\left(x\\\\right)^{2}";
final String subst = "\\1\\3\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}