$re = '/(\\\\{2}sin|cos|tan|sec|log)([^^]*)(\^\{[^}]*\})/';
$str = '\\\\sin\\\\left(x\\\\right)^{2}';
$subst = "\1\3\2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;