re = /(\\{2}sin|cos|tan|sec|log)([^^]*)(\^\{[^}]*\})/
str = '\\\\sin\\\\left(x\\\\right)^{2}'
subst = '\\1\\3\\2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result