// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\\{2}sin|cos|tan|sec|log)([^^]*)(\^\{[^}]*\})").unwrap();
let string = "\\\\sin\\\\left(x\\\\right)^{2}";
let substitution = "\\1\\3\\2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}