using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]{1,6})\s{0,5}([0-9]{2})([0-9]{2})([0-9]{2})(C|P)([0-9]{5})([0-9]{3})";
string input = @"MSFT 060318C00047500";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}