// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([A-Z]{1,6})\s{0,5}([0-9]{2})([0-9]{2})([0-9]{2})(C|P)([0-9]{5})([0-9]{3})").unwrap();
let string = "MSFT 060318C00047500";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}