import re
regex = re.compile(r"([A-Z]{1,6})\s{0,5}([0-9]{2})([0-9]{2})([0-9]{2})(C|P)([0-9]{5})([0-9]{3})", flags=re.IGNORECASE)
test_str = "MSFT 060318C00047500"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")