$re = '/([A-Z]{1,6})\s{0,5}([0-9]{2})([0-9]{2})([0-9]{2})(C|P)([0-9]{5})([0-9]{3})/i';
$str = 'MSFT 060318C00047500';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);