import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+|-|)(\\d+\\.|\\.\\d+|\\d+|\\d+\\.\\d+)((e+|e-|e)\\d+)?$";
final String string = "1+1\n"
+ "1f5";
final String subst = "$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}