import Foundation
let pattern = #"^(\+|-|)(\d+\.|\.\d+|\d+|\d+\.\d+)((e+|e-|e)\d+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1+1
1f5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)