#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)data:\s*{\s*url:\s*'stage-player-stat'\s*},\s*defaultParams:\s*{\s*(.*?),.*},"
Local $sString = "data:{" & @CRLF & _
" url: 'stage-player-stat'" & @CRLF & _
" }," & @CRLF & _
" defaultParams: {" & @CRLF & _
" stageId: 9155," & @CRLF & _
" teamId: 32," & @CRLF & _
" playerId: -1," & @CRLF & _
" field: 2" & @CRLF & _
" },"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)