$re = '/data:\s*{\s*url:\s*\'stage-player-stat\'\s*},\s*defaultParams:\s*{\s*(.*?),.*},/s';
$str = 'data:{
url: \'stage-player-stat\'
},
defaultParams: {
stageId: 9155,
teamId: 32,
playerId: -1,
field: 2
},';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;