# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"data:\s*{\s*url:\s*'stage-player-stat'\s*},\s*defaultParams:\s*{\s*(.*?),.*},"
test_str = ("data:{\n"
" url: 'stage-player-stat'\n"
" },\n"
" defaultParams: {\n"
" stageId: 9155,\n"
" teamId: 32,\n"
" playerId: -1,\n"
" field: 2\n"
" },")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.