const regex = /(x+x+)+y/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(x+x+)+y', 'gm')
const str = `
xxxxxxxxxxxxxxxx
Catastrophic backtracking example:
Note the pattern looks fairly simple, but it needs over 80000 steps to decide it is not a match.
With just 16 'x' it already takes a large amount of steps to finally decides it does not work.
(click "regex debugger" on the left to see details on steps taken)
See https://www.regular-expressions.info/catastrophic.html for more info.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}