import re
regex = re.compile(r"([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})")
test_str = (" 42 0050.348a.7a93 dynamic ~~~ F F Po3\n"
"* 82 3550.b5e7.0124 dynamic ~~~ F F Po1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")