re = /([0-9a-f]{4}[\.][0-9a-f]{4}[\.][0-9a-f]{4})/
str = ' 42 0050.348a.7a93 dynamic ~~~ F F Po3
* 82 3550.b5e7.0124 dynamic ~~~ F F Po1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end