using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(.)(?!\1)).*(*SKIP)(*F)|.";
string substitution = @"x";
string input = @"sssppaaasspaapppssss";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}