const regex = /(?<=(.)(?!\1)).*(*SKIP)(*F)|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(.)(?!\\1)).*(*SKIP)(*F)|.', 'gm')
const str = `sssppaaasspaapppssss`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);