$re = '/(?<=(.)(?!\1)).*(*SKIP)(*F)|./m';
$str = 'sssppaaasspaapppssss';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;