re = /(?<=(.)(?!\1)).*(*SKIP)(*F)|./m
str = 'sssppaaasspaapppssss'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result