#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(172)\.(1[6-9]|2[0-9]|3[0-1])(\.(2[0-4][0-9]|25[0-5]|[1][0-9][0-9]|[1-9][0-9]|[0-9])){2}(\/(1[6-9]|2[0-9]|3[0-2]))"
Local $sString = "172.15.0.0/16" & @CRLF & _
"172.16.0.0/16" & @CRLF & _
"172.17.0.0/15" & @CRLF & _
"172.31.0.0/16" & @CRLF & _
"172.32.0.0/32" & @CRLF & _
"172.50.0.0/16" & @CRLF & _
"172.20.0.0/22" & @CRLF & _
"172.28.0.0/26"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")