const regex = /(172)\.(1[6-9]|2[0-9]|3[0-1])(\.(2[0-4][0-9]|25[0-5]|[1][0-9][0-9]|[1-9][0-9]|[0-9])){2}(\/(1[6-9]|2[0-9]|3[0-2]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(172)\\.(1[6-9]|2[0-9]|3[0-1])(\\.(2[0-4][0-9]|25[0-5]|[1][0-9][0-9]|[1-9][0-9]|[0-9])){2}(\\\/(1[6-9]|2[0-9]|3[0-2]))', 'gm')
const str = `172.15.0.0/16
172.16.0.0/16
172.17.0.0/15
172.31.0.0/16
172.32.0.0/32
172.50.0.0/16
172.20.0.0/22
172.28.0.0/26`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}