import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(172)\\.(1[6-9]|2[0-9]|3[0-1])(\\.(2[0-4][0-9]|25[0-5]|[1][0-9][0-9]|[1-9][0-9]|[0-9])){2}(\\/(1[6-9]|2[0-9]|3[0-2]))";
final String string = "172.15.0.0/16\n"
+ "172.16.0.0/16\n"
+ "172.17.0.0/15\n"
+ "172.31.0.0/16\n"
+ "172.32.0.0/32\n"
+ "172.50.0.0/16\n"
+ "172.20.0.0/22\n"
+ "172.28.0.0/26";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}