// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(172)\.(1[6-9]|2[0-9]|3[0-1])(\.(2[0-4][0-9]|25[0-5]|[1][0-9][0-9]|[1-9][0-9]|[0-9])){2}(\/(1[6-9]|2[0-9]|3[0-2]))").unwrap();
let string = "172.15.0.0/16
172.16.0.0/16
172.17.0.0/15
172.31.0.0/16
172.32.0.0/32
172.50.0.0/16
172.20.0.0/22
172.28.0.0/26";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}