using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w{3}\/)([a-zA-z0-9]*)(\-\w{1,})$";
string input = @"SIP/nomclient-xxxx
SIP/nomclient-zess
TAT/nomclient-xxxx";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}