const regex = /^(\w{3}\/)([a-zA-z0-9]*)(\-\w{1,})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w{3}\\\/)([a-zA-z0-9]*)(\\-\\w{1,})$', 'gmi')
const str = `SIP/nomclient-xxxx
SIP/nomclient-zess
TAT/nomclient-xxxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}