// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(\w{3}\/)([a-zA-z0-9]*)(\-\w{1,})$").unwrap();
let string = "SIP/nomclient-xxxx
SIP/nomclient-zess
TAT/nomclient-xxxx";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}